Skip to content
Not rated

CVE-2026-73633 Uncontrolled resource consumption vulnerability in the JSON plugin of Apache Struts

Description

Uncontrolled resource consumption vulnerability in the JSON plugin of Apache Struts. When an application is configured to populate actions from a JSON request body, the plugin reads that body into memory without bounding how much it will accept, so a single request can exhaust the heap and deny service to other users. The plugin's configurable JSON input length limit does not bound this read. The JSON plugin is an optional component; applications that do not use it, or use it without enabling JSON request-body handling, are not affected. This issue affects Apache Struts: from 2.1.8 through 2.3.37, from 2.5.0 through 2.5.33, from 6.0.0 through 6.10.0, from 7.0.0 through 7.2.1. Users are recommended to upgrade to version 6.11.0 or 7.3.0, which fixes the issue.

Affected products and versions

Product Affected versions Fixed in
Apache Struts 7.0 7.0.0 → 7.2.1 No fix stated
Apache Struts 6.0 6.0.0 → 6.10.0 No fix stated
Apache Struts 2.5 2.5.0 → 2.5.33 No fix stated
Apache Struts 2.1 2.1.8 → 2.3.37 No fix stated

References

Timeline

  1. Published
  2. Last modified
The 33 CVEs of Apache Struts →
Track this CVE