Skip to content
Not rated

CVE-2026-49877 Improper Authorization vulnerability in Apache ActiveMQ

Description

Improper Authorization vulnerability in Apache ActiveMQ. An authenticated low-privilege Web Console user by default can access /admin/* paths in the Web Console. The default Jetty settings incorrectly did not limit those paths to only admins. This issue affects Apache ActiveMQ: before 5.19.8, from 6.0.0 before 6.2.7. Users are recommended to upgrade to version 6.2.7 or 5.19.8, which fixes the issue.

Affected products and versions

Product Affected versions Fixed in
Apache ActiveMQ 6.0 6.0.0 → < 6.2.7 6.2.7
Apache ActiveMQ 5.19 earliest → < 5.19.8 5.19.8

References

Timeline

  1. Published
  2. Last modified
The 40 CVEs of Apache ActiveMQ →
Track this CVE