Skip to content
2.1 Low

CVE-2026-49871 Cross-Site Request Forgery (CSRF) vulnerability in the cas-auth plugin under default configurations

Description

Cross-Site Request Forgery (CSRF) vulnerability in the cas-auth plugin under default configurations. This defect allows a remote attacker that manages to send a victim to a webpage controlled by them can cause the victim's browser to become authenticated as a different identity. Actions the victim takes upstream are then attributed to attackers identity. This issue affects Apache APISIX: from 3.0.0 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.

Affected products and versions

Product Affected versions Fixed in
Apache APISIX 3.0 3.0.0 → 3.16.0 No fix stated

References

Timeline

  1. Published
  2. Last modified
The 34 CVEs of Apache APISIX →
Track this CVE