Skip to content
Not rated

CVE-2026-49042 Improper Input Validation vulnerability in Apache Camel

Description

Improper Input Validation vulnerability in Apache Camel. This issue affects Apache Camel: from 4.8.0 through 4.18.2, from 4.19.0 through 4.20.0. Users are recommended to upgrade to version 4.18.3, 4.21.0, which fixes the issue.

Affected products and versions

Product Affected versions Fixed in
Apache Camel 4.19 4.19.0 → 4.20.0 No fix stated
Apache Camel 4.8 4.8.0 → 4.18.2 No fix stated

References

Timeline

  1. Published
  2. Last modified
The 97 CVEs of Apache Camel →
Track this CVE