Not rated
CVE-2026-46605 Incomplete authorization by Apache ActiveMQ server before versions v6.2.6 and v5.19.7 allows authenticated connections…
Description
Incomplete authorization by Apache ActiveMQ server before versions v6.2.6 and v5.19.7 allows authenticated connections to remove existing destinations with proper permissions. This issue affects Apache ActiveMQ Broker: before 5.19.7, from 6.0.0 before 6.2.6; Apache ActiveMQ All: before 5.19.7, from 6.0.0 before 6.2.6; Apache ActiveMQ: before 5.19.7, from 6.0.0 before 6.2.6. Users are recommended to upgrade to version v6.2.6 or v5.19.7, which fixes the issue.
Affected products and versions
| Product | Affected versions | Fixed in |
|---|---|---|
| Apache ActiveMQ Broker 6.0 | 6.0.0 → < 6.2.6 | 6.2.6 |
| Apache ActiveMQ Broker 5.19 | earliest → < 5.19.7 | 5.19.7 |
| Apache ActiveMQ All 6.0 | 6.0.0 → < 6.2.6 | 6.2.6 |
| Apache ActiveMQ All 5.19 | earliest → < 5.19.7 | 5.19.7 |
| Apache ActiveMQ 6.0 | 6.0.0 → < 6.2.6 | 6.2.6 |
| Apache ActiveMQ 5.19 | earliest → < 5.19.7 | 5.19.7 |
References
- lists.apache.org lists.apache.org
Timeline
- Published
- Last modified
Other CVEs of Apache ActiveMQ Broker
The 15 CVEs of Apache ActiveMQ Broker →
CVE-2026-74761
Improper input validation in TopicRegion in Apache ActiveMQ, Apache ActiveMQ Broker, and Apache ActiveMQ All on all…
Not rated
CVE-2026-61487
Improper Authorization vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ
Not rated
CVE-2026-49434
Improper Input Validation vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ, Apache ActiveMQ All
Not rated
CVE-2026-50750
Denial of Service via Out of Memory vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ, Apache ActiveMQ All
Not rated