Skip to content
5.3 Medium

CVE-2026-44087 Insufficient Verification of Data Authenticity vulnerability in Apache APISIX

Description

Insufficient Verification of Data Authenticity vulnerability in Apache APISIX. The openid-connect plugin under default configuration has an attack surface that allows the attacker to spoof identity headers allowing the attacker to get unauthorized access the protected resources. This issue affects Apache APISIX: from 2.3 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.

Affected products and versions

Product Affected versions Fixed in
Apache APISIX 2.3 2.3 → 3.16.0 No fix stated

References

Timeline

  1. Published
  2. Last modified
The 34 CVEs of Apache APISIX →
Track this CVE