Skip to content
Not rated

CVE-2026-31908 Header injection vulnerability in Apache APISIX

Description

Header injection vulnerability in Apache APISIX. The attacker can take advantage of certain configuration in forward-auth plugin to inject malicious headers. This issue affects Apache APISIX: from 2.12.0 through 3.15.0. Users are recommended to upgrade to version 3.16.0, which fixes the issue.

Affected products and versions

Product Affected versions Fixed in
Apache APISIX 2.12 2.12.0 → 3.15.0 No fix stated

References

Timeline

  1. Published
  2. Last modified
The 34 CVEs of Apache APISIX →
Track this CVE