7.4
High
CVE-2026-18394 Incorrect authorization in the http_request tool in Strands Agents Tools before 0.8.2 might allow remote attackers to…
Description
Incorrect authorization in the http_request tool in Strands Agents Tools before 0.8.2 might allow remote attackers to obtain credentials configured via HTTP_REQUEST_TOKEN_CONFIG by influencing the LLM to route requests through actor-controlled proxy infrastructure. To remediate this issue, users should upgrade to version 0.8.2.
Affected products and versions
| Product | Affected versions | Fixed in |
|---|---|---|
| Strands Agents Tools 0.8 | earliest → < 0.8.2 | 0.8.2 |