Skip to content
8.5 High

CVE-2025-48977 Relative Path Traversal vulnerability in Apache Ignite REST API

Description

Relative Path Traversal vulnerability in Apache Ignite REST API. Authenticated REST API users can read any file on the server with "cmd=log" command and a log path crafted in a certain way. This issue affects Apache Ignite: from 2.0.0 through 2.17.0. Users are recommended to upgrade to version 2.18.0, which fixes the issue.

Affected products and versions

Product Affected versions Fixed in
Apache Ignite 2.0 2.0.0 → 2.17.0 No fix stated
The 5 CVEs of Apache Ignite →
Track this CVE