5.3
Medium
CVE-2025-2175 A vulnerability was found in libzvbi up to 0.2.43
Description
A vulnerability was found in libzvbi up to 0.2.43. It has been rated as problematic. Affected by this issue is the function _vbi_strndup_iconv. The manipulation leads to integer overflow. The attack may be launched remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 0.2.44 is able to address this issue. It is recommended to upgrade the affected component. The code maintainer was informed beforehand about the issues. She reacted very fast and highly professional.
Affected products and versions
| Product | Affected versions | Fixed in |
|---|---|---|
| libzvbi 0.2 | 0.2.0 → 0.2.43 | No fix stated |
Other CVEs of libzvbi
The 5 CVEs of libzvbi →
CVE-2025-2177
A vulnerability classified as critical was found in libzvbi up to 0.2.43
6.9
Medium
CVE-2025-2176
A vulnerability classified as critical has been found in libzvbi up to 0.2.43
6.9
Medium
CVE-2025-2174
A vulnerability was found in libzvbi up to 0.2.43
6.9
Medium
CVE-2025-2173
A vulnerability was found in libzvbi up to 0.2.43
6.9
Medium