Skip to content
6.4 Medium

CVE-2025-14865 The Passster – Password Protect Pages and Content plugin for WordPress is vulnerable to Stored Cross-Site Scripting…

Description

The Passster – Password Protect Pages and Content plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'content_protector' shortcode in all versions up to, and including, 4.2.24. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The vulnerability was partially patched in version 4.2.21.

Affected products and versions

Product Affected versions Fixed in
Passster – Password Protect Pages and Content 4.2 earliest → 4.2.24 No fix stated
The 5 CVEs of Passster – Password Protect Pages and Content →
Track this CVE