Skip to content
5.3 Medium

CVE-2025-14507 The EventPrime - Events Calendar, Bookings and Tickets plugin for WordPress is vulnerable to Sensitive Information…

Description

The EventPrime - Events Calendar, Bookings and Tickets plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 4.2.7.0 via the REST API. This makes it possible for unauthenticated attackers to extract sensitive booking data including user names, email addresses, ticket details, payment information, and order keys when the API is enabled by an administrator. The vulnerability was partially patched in version 4.2.7.0.

Affected products and versions

Product Affected versions Fixed in
EventPrime – Events Calendar, Bookings and Tickets 4.2 earliest → 4.2.7.0 No fix stated
The 17 CVEs of EventPrime – Events Calendar, Bookings and Tickets →
Track this CVE