6.9
Medium
CVE-2024-7272 A vulnerability, which was classified as critical, was found in FFmpeg up to 5.1.5
Description
A vulnerability, which was classified as critical, was found in FFmpeg up to 5.1.5. This affects the function fill_audiodata of the file /libswresample/swresample.c. The manipulation leads to heap-based buffer overflow. It is possible to initiate the attack remotely. This issue was fixed in version 6.0 by 9903ba28c28ab18dc7b7b6fb8571cc8b5caae1a6 but a backport for 5.1 was forgotten. The exploit has been disclosed to the public and may be used. Upgrading to version 5.1.6 and 6.0 9903ba28c28ab18dc7b7b6fb8571cc8b5caae1a6 is able to address this issue. It is recommended to upgrade the affected component.
Affected products and versions
References
- VDB-273945 | FFmpeg swresample.c fill_audiodata heap-based overflow vuldb.com
- VDB-273945 | CTI Indicators (IOB, IOC, IOA) vuldb.com
- github.com github.com
- github.com github.com
- ffmpeg.org ffmpeg.org
Timeline
- Published
- Last modified
Other CVEs of ffmpeg
The 11 CVEs of ffmpeg →
CVE-2026-90816
A vulnerability was found in FFmpeg 8.0.x
5.3
Medium
CVE-2026-90815
A vulnerability has been found in FFmpeg up to 4.4.6/5.1.8/6.1.4/7.1.3/8.0.1
5.3
Medium
CVE-2025-1816
A vulnerability classified as problematic has been found in FFmpeg up to 6e26f57f672b05e7b8b052007a83aef99dc81ccb
5.3
Medium
CVE-2025-1594
A vulnerability, which was classified as critical, was found in FFmpeg up to 7.1
5.3
Medium