Skip to content
Not rated

CVE-2024-43115 Improper Input Validation vulnerability in Apache DolphinScheduler

Description

Improper Input Validation vulnerability in Apache DolphinScheduler. An authenticated user can execute any shell script server by alert script. This issue affects Apache DolphinScheduler: before 3.2.2. Users are recommended to upgrade to version 3.3.1, which fixes the issue.

Affected products and versions

Product Affected versions Fixed in
Apache DolphinScheduler 3.2 earliest → < 3.2.2 3.2.2

References

Timeline

  1. Published
  2. Last modified
The 46 CVEs of Apache DolphinScheduler →
Track this CVE