Skip to content
Not rated

CVE-2024-31860 Improper Input Validation vulnerability in Apache Zeppelin

Description

Improper Input Validation vulnerability in Apache Zeppelin. By adding relative path indicators(E.g ..), attackers can see the contents for any files in the filesystem that the server account can access.  This issue affects Apache Zeppelin: from 0.9.0 before 0.11.0. Users are recommended to upgrade to version 0.11.0, which fixes the issue.

Affected products and versions

Product Affected versions Fixed in
Apache Zeppelin 0.9 0.9.0 → < 0.11.0 0.11.0
zeppelin 0.9.0 No fix stated

References

Timeline

  1. Published
  2. Last modified
The 25 CVEs of Apache Zeppelin →
Track this CVE