Skip to content
4.3 Medium

CVE-2024-28148 An authenticated user could potentially access metadata for a datasource they are not authorized to view by submitting a…

Description

An authenticated user could potentially access metadata for a datasource they are not authorized to view by submitting a targeted REST API request.This issue affects Apache Superset: before 3.1.2. Users are recommended to upgrade to version 3.1.2 or above, which fixes the issue.

Affected products and versions

Product Affected versions Fixed in
Apache Superset 3.1 earliest → < 3.1.2 3.1.2

References

Timeline

  1. Published
  2. Last modified
The 65 CVEs of Apache Superset →
Track this CVE