Skip to content
Not rated

CVE-2023-46749 Apache Shiro before 1.13.0 or 2.0.0-alpha-4, may be susceptible to a path traversal attack that results in an…

Description

Apache Shiro before 1.13.0 or 2.0.0-alpha-4, may be susceptible to a path traversal attack that results in an authentication bypass when used together with path rewriting Mitigation: Update to Apache Shiro 1.13.0+ or 2.0.0-alpha-4+, or ensure `blockSemicolon` is enabled (this is the default).

Affected products and versions

Product Affected versions Fixed in
Apache Shiro 2.0 2.0.0-alpha-1 → < 2.0.0-alpha-4 2.0.0-alpha-4
Apache Shiro 1.13 earliest → < 1.13.0 1.13.0

References

Timeline

  1. Published
  2. Last modified
The 17 CVEs of Apache Shiro →
Track this CVE