Skip to content
8.2 High

CVE-2026-56091 When using Apache Shiro with the shiro-guice module in a web servlet context, a specially crafted HTTP request may cause…

Description

When using Apache Shiro with the shiro-guice module in a web servlet context, a specially crafted HTTP request may cause an authentication bypass. This vulnerability is similar to https://www.cve.org/CVERecord?id=CVE-2020-1957 https://www.cve.org/CVERecord , except that it affects the `shiro-guice` module instead of the `shiro-spring` module. This issue affects all Apache Shiro versions through 2.x, and 3.0.0-alpha-1 only when using `shiro-guice` module in a web servlet context. Upgrade to version 3.0.0 or later, which fixes the issue.

Affected products and versions

Product Affected versions Fixed in
Apache Shiro 3.0 3.0.0-alpha-0 → 3.0.0-alpha-1 No fix stated
Apache Shiro 2.99 earliest → 2.99.99 No fix stated

References

Timeline

  1. Published
  2. Last modified
The 17 CVEs of Apache Shiro →
Track this CVE