Not rated
CVE-2022-44635 Apache Fineract allowed an authenticated user to perform remote code execution due to a path traversal vulnerability…
Description
Apache Fineract allowed an authenticated user to perform remote code execution due to a path traversal vulnerability in a file upload component of Apache Fineract, allowing an attacker to run remote code. This issue affects Apache Fineract version 1.8.0 and prior versions. We recommend users to upgrade to 1.8.1.
Affected products and versions
| Product | Affected versions | Fixed in |
|---|---|---|
| Apache Fineract 1.8 | earliest → 1.8.0 | No fix stated |
| Apache Fineract 1.7 | earliest → 1.7.0 | No fix stated |
Other CVEs of Apache Fineract
The 22 CVEs of Apache Fineract →
CVE-2026-64618
Apache Fineract: SQL injection vulnerability in Search API
Not rated
CVE-2026-65874
Apache Fineract: SQL injection via ORDER BY parameters in the Center and datatables endpoints
Not rated
CVE-2026-57821
A SQL Injection vulnerability exists in Apache Fineract's Office Search API (GET /api/v1/offices) in versions up to…
Not rated
CVE-2026-35152
A SQL Injection vulnerability exists in Apache Fineract's Report Execution API (runreports endpoint) in versions up to…
Not rated