Skip to content
Not rated

CVE-2021-40865 An Unsafe Deserialization vulnerability exists in the worker services of the Apache Storm supervisor server allowing…

Description

An Unsafe Deserialization vulnerability exists in the worker services of the Apache Storm supervisor server allowing pre-auth Remote Code Execution (RCE). Apache Storm 2.2.x users should upgrade to version 2.2.1 or 2.3.0. Apache Storm 2.1.x users should upgrade to version 2.1.1. Apache Storm 1.x users should upgrade to version 1.2.4

Affected products and versions

Product Affected versions Fixed in
Apache Storm 1.2 earliest → < 1.2.4 1.2.4
Apache Storm 1.0 1.0.0 → latest No fix stated
The 7 CVEs of Apache Storm →
Track this CVE