Not rated
CVE-2021-33036 In Apache Hadoop 2.2.0 to 2.10.1, 3.0.0-alpha1 to 3.1.4, 3.2.0 to 3.2.2, and 3.3.0 to 3.3.1, a user who can escalate…
Description
In Apache Hadoop 2.2.0 to 2.10.1, 3.0.0-alpha1 to 3.1.4, 3.2.0 to 3.2.2, and 3.3.0 to 3.3.1, a user who can escalate to yarn user can possibly run arbitrary commands as root user. Users should upgrade to Apache Hadoop 2.10.2, 3.2.3, 3.3.2 or higher.
Affected products and versions
| Product | Affected versions | Fixed in |
|---|---|---|
| Apache Hadoop | Versions not published |
References
- lists.apache.org lists.apache.org
- [oss-security] 20220615 CVE-2021-33036: Apache Hadoop Privilege escalation vulnerability www.openwall.com
- security.netapp.com security.netapp.com
Timeline
- Published
- Last modified
Other CVEs of Apache Hadoop
The 18 CVEs of Apache Hadoop →
CVE-2024-23454
Apache Hadoop’s RunJar.run() does not set permissions for temporary directory by default
Not rated
CVE-2023-26031
Relative library resolution in linux container-executor binary in Apache Hadoop 3.3.1-3.3.4 on Linux allows local user…
Not rated
CVE-2021-25642
ZKConfigurationStore which is optionally used by CapacityScheduler of Apache Hadoop YARN deserializes data obtained from…
Not rated
CVE-2022-25168
Apache Hadoop's FileUtil.unTar(File, File) API does not escape the input file name before being passed to the shell
Not rated