Not rated
CVE-2026-86247 Race condition within a thread vulnerability in Apache Tomcat Native allowed client certificate verification…
Description
Race condition within a thread vulnerability in Apache Tomcat Native allowed client certificate verification requirements to be down-graded for some configurations. This issue affects Apache Tomcat Native: from 2.0.0 through 2.0.15, from 1.3.0 through 1.3.8. Unsupported versions may also be affected. Users are recommended to upgrade to version 2.0.16 or 1.3.9, which fixes the issue.
Affected products and versions
| Product | Affected versions | Fixed in |
|---|---|---|
| Apache Tomcat Native 2.0 | 2.0.0 → 2.0.15 | No fix stated |
| Apache Tomcat Native 1.3 | 1.3.0 → 1.3.8 | No fix stated |
Other CVEs of Apache Tomcat Native
The 8 CVEs of Apache Tomcat Native →
CVE-2026-86246
Initialization of a resource with an insecure default vulnerability in Apache Tomcat Native enabled insecure…
Not rated
CVE-2026-86243
Buffer over-read vulnerability in Apache Tomcat Native during the TLS handshake permits a malicious user to trigger a…
Not rated
CVE-2026-29145
CLIENT_CERT authentication does not fail as expected for some scenarios when soft fail is disabled vulnerability in…
Not rated
CVE-2026-24734
Improper Input Validation vulnerability in Apache Tomcat Native, Apache Tomcat
Not rated