Skip to content
5.3 Medium

CVE-2026-49872 Improper Authentication vulnerability in Apache APISIX

Description

Improper Authentication vulnerability in Apache APISIX. When the cas-auth plugin is used in a route, an attacker can possibly authenticate itself with credentials from a different source. This issue affects Apache APISIX: from 3.0.0 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.

Affected products and versions

Product Affected versions Fixed in
Apache APISIX 3.0 3.0.0 → 3.16.0 No fix stated

References

Timeline

  1. Published
  2. Last modified
The 34 CVEs of Apache APISIX →
Track this CVE