Skip to content
Not rated

CVE-2026-31923 Cleartext Transmission of Sensitive Information vulnerability in Apache APISIX

Description

Cleartext Transmission of Sensitive Information vulnerability in Apache APISIX. This can occur due to `ssl_verify` in openid-connect plugin configuration being set to false by default. This issue affects Apache APISIX: from 0.7 through 3.15.0. Users are recommended to upgrade to version 3.16.0, which fixes the issue.

Affected products and versions

Product Affected versions Fixed in
Apache APISIX 0.7 0.7 → 3.15.0 No fix stated

References

Timeline

  1. Published
  2. Last modified
The 34 CVEs of Apache APISIX →
Track this CVE