8.5
High
CVE-2025-48977 Relative Path Traversal vulnerability in Apache Ignite REST API
Description
Relative Path Traversal vulnerability in Apache Ignite REST API. Authenticated REST API users can read any file on the server with "cmd=log" command and a log path crafted in a certain way. This issue affects Apache Ignite: from 2.0.0 through 2.17.0. Users are recommended to upgrade to version 2.18.0, which fixes the issue.
Affected products and versions
| Product | Affected versions | Fixed in |
|---|---|---|
| Apache Ignite 2.0 | 2.0.0 → 2.17.0 | No fix stated |
Other CVEs of Apache Ignite
The 5 CVEs of Apache Ignite →
CVE-2024-52577
In Apache Ignite versions from 2.6.0 and before 2.17.0, configured Class Serialization Filters are ignored for some…
9.5
Critical
CVE-2018-8018
In Apache Ignite before 2.4.8 and 2.5.x before 2.5.3, the serialization mechanism does not have a list of classes…
Not rated
CVE-2018-1295
In Apache Ignite 2.3 or earlier, the serialization mechanism does not have a list of classes allowed for…
Not rated
CVE-2017-7686
Apache Ignite 1.0.0-RC3 to 2.0 uses an update notifier component to update the users about new project releases that…
Not rated