Skip to content
7.1 High

CVE-2024-10944 A Remote Code Execution vulnerability exists in the affected product

Description

A Remote Code Execution vulnerability exists in the affected product. The vulnerability requires a high level of permissions and exists due to improper input validation resulting in the possibility of a malicious Updated Agent being deployed.

Affected products and versions

Product Affected versions Fixed in
FactoryTalk Updater 4.20 earliest → < 4.20.00 4.20.00
factorytalk_updater 4.00 4.00.00 → 4.20.00 No fix stated
The 3 CVEs of FactoryTalk Updater →
Track this CVE