Skip to content
7.5 High

CVE-2023-43826 Apache Guacamole 1.5.3 and older do not consistently ensure that values received from a VNC server will not result in…

Description

Apache Guacamole 1.5.3 and older do not consistently ensure that values received from a VNC server will not result in integer overflow. If a user connects to a malicious or compromised VNC server, specially-crafted data could result in memory corruption, possibly allowing arbitrary code to be executed with the privileges of the running guacd process. Users are recommended to upgrade to version 1.5.4, which fixes this issue.

Affected products and versions

Product Affected versions Fixed in
Apache Guacamole 1.5 earliest → 1.5.3 No fix stated
The 8 CVEs of Apache Guacamole →
Track this CVE