Not rated
CVE-2021-40369 A carefully crafted plugin link invocation could trigger an XSS vulnerability on Apache JSPWiki, related to the Denounce…
Description
A carefully crafted plugin link invocation could trigger an XSS vulnerability on Apache JSPWiki, related to the Denounce plugin, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim. Apache JSPWiki users should upgrade to 2.11.0 or later.
Affected products and versions
| Product | Affected versions | Fixed in |
|---|---|---|
| Apache JSPWiki 2.11 | earliest → 2.11.0.M8 | No fix stated |
References
- jspwiki-wiki.apache.org jspwiki-wiki.apache.org
- lists.apache.org lists.apache.org
- [oss-security] 20220803 CVE-2022-28730: Apache JSPWiki Cross-site scripting vulnerability on AJAXPreview.jsp www.openwall.com
Timeline
- Published
- Last modified
Other CVEs of Apache JSPWiki
The 22 CVEs of Apache JSPWiki →
CVE-2026-48910
A carefully crafted editing request could trigger an XSS vulnerability on Apache JSPWiki when parsing errors on the…
Not rated
CVE-2026-28814
Arbitrary Wiki Markup rendering due to lack of authentication in Apache JSPWiki up to 2.12.3 allows attacker to obtain…
Not rated
CVE-2026-28813
Apache JSPWiki, up to 2.12.3, is vulnerable to JSON Hijacking, which leads to csrf vulnerabilities
Not rated
CVE-2026-28812
UserManager lack of checks allows impersonation in Apache JSPWiki up to 2.12.3 which may allow attackers to escalate…
Not rated