Aller au contenu
6.9 Moyenne

CVE-2026-92415 — Use of Externally-Controlled Input to Select Classes or Code vulnerability in Apache Jackrabbit's WebDAV/Davex client

Description

— Use of Externally-Controlled Input to Select Classes or Code vulnerability in Apache Jackrabbit's WebDAV/Davex client. A malicious WebDAV/DavEx server, or an attacker able to intercept the connection, can cause the client to instantiate arbitrary classes from its classpath, which can lead to arbitrary file creation or truncation. Only applications that use jackrabbit-spi2dav (directly or through jackrabbit-jcr2dav) to connect to a remote repository are affected. Jackrabbit servers are not affected. Category: unsafe reflection on wire data (HIGH). This issue affects Apache Jackrabbit: from 2.23.0 through 2.23.5, from 2.22.0 through 2.22.4, from 2.20.0 through 2.20.17. Users are recommended to upgrade to versions 2.23.6, 2.22.5, or 2.20.18 which fix the issue.

Produits et versions touchés

Produit Versions touchées Corrigé en
Apache Jackrabbit 2.23 2.23.0 → 2.23.5 Pas de correctif indiqué
Apache Jackrabbit 2.22 2.22.0 → 2.22.4 Pas de correctif indiqué
Apache Jackrabbit 2.20 2.20.0 → 2.20.17 Pas de correctif indiqué
Les 3 CVE de Apache Jackrabbit →
Suivre cette CVE