6.7
Moyenne
CVE-2026-88922 The go-getter library up to versions 1.8.8 and 2.2.3 is vulnerable to a privilege escalation issue in its archive…
Description
The go-getter library up to versions 1.8.8 and 2.2.3 is vulnerable to a privilege escalation issue in its archive decompression handling that may allow a crafted archive to cause extracted files to be created with elevated permission bits. Where extraction is performed by a privileged user, this may allow a local actor to obtain the privileges of the extracting process. This vulnerability (CVE-2026-88922) is fixed in go-getter 1.8.9 and 2.2.4.
Produits et versions touchés
| Produit | Versions touchées | Corrigé en |
|---|---|---|
| Shared library 1.0 | 1.0.1 → < 2.2.4 | 2.2.4 |
Autres CVE de Shared library
Les 10 CVE de Shared library →
CVE-2026-19585
HashiCorp go-getter versions before 1.8.10 and go-getter/v2 versions before 2.2.5 are vulnerable to path traversal…
5.3
Moyenne
CVE-2026-14362
HashiCorp memberlist before version 0.6.0 is vulnerable to a denial-of-service issue in its push/pull state handling…
4.9
Moyenne
CVE-2026-8052
HashiCorp Nomad’s exec2 task driver prior to 0.1.2 is vulnerable to arbitrary file read and write on the client host…
6.0
Moyenne
CVE-2026-0969
The serialize function used to compile MDX in next-mdx-remote is vulnerable to arbitrary code execution due to…
8.8
Élevée