Aller au contenu
7.5 Élevée

CVE-2026-7776 Boundary Community Edition and Boundary Enterprise (“Boundary”) workers are vulnerable to a denial-of-service…

Description

Boundary Community Edition and Boundary Enterprise (“Boundary”) workers are vulnerable to a denial-of-service condition during node enrollment TLS handshakes. An attacker with network access to the worker authentication listener may open a connection and delay or withhold the client certificate during the TLS handshake, causing worker connection handling to block. This may prevent legitimate worker connections from being accepted or routed. This vulnerability, CVE-2026-7776, is fixed in Boundary 0.21.3, 0.20.3, 0.19.5.

Produits et versions touchés

Produit Versions touchées Corrigé en
Boundary 0.9 0.9.0 → < 0.21.3 0.21.3
Boundary Enterprise 0.9 0.9.0 → < 0.21.3 0.21.3

Références

Chronologie

  1. Publiée
  2. Dernière modification
Les 5 CVE de Boundary →
Suivre cette CVE