Aller au contenu
7.7 Élevée

CVE-2026-73626 JupyterLab versions…

Description

JupyterLab versions >=4.6.0,<=4.6.1 and <=4.5.9 contain an allowlist/blocklist enforcement gap in PyPIExtensionManager.install(). A missing 'await' caused the is_install_allowed coroutine to never execute, so the extension allowlist/blocklist check was not enforced for direct callers of install(). The stock JupyterLab HTTP API and Extension Manager UI are not affected, as they perform a separate, correctly awaited check. The issue affects only deployments where a custom extension or downstream integration imports PyPIExtensionManager and calls install() directly with a package name influenced by untrusted input, an allowlist/blocklist is configured, the PyPI Extension Manager is enabled, and kernels and terminals are disabled or delegated to remote hosts. Fixed in JupyterLab 4.6.2 and 4.5.10.

Produits et versions touchés

Produit Versions touchées Corrigé en
jupyterlab 4.5 premières → < 4.5.10 4.5.10

Références

Chronologie

  1. Publiée
  2. Dernière modification
Les 18 CVE de jupyterlab →
Suivre cette CVE