Non notée
CVE-2026-59878 Improper Input Validation vulnerability in Apache ActiveMQ AMQP, Apache ActiveMQ, Apache ActiveMQ All
Description
Improper Input Validation vulnerability in Apache ActiveMQ AMQP, Apache ActiveMQ, Apache ActiveMQ All. A remote unauthenticated peer that can reach an exposed AMQP NIO connector can trigger denial-of-service behavior by sending a frame size value. This cause the NIO threads to die and if done rapidly enough can lead to exhaustion of the NIO thread pool denying service to other connections. This issue affects Apache ActiveMQ AMQP: before 5.19.9, from 6.0.0 before 6.2.8; Apache ActiveMQ: before 5.19.9, from 6.0.0 before 6.2.8; Apache ActiveMQ All: before 5.19.9, from 6.0.0 before 6.2.8. Users are recommended to upgrade to version 5.19.9, 6.2.8, or 6.3.0 which fixes the issue.
Produits et versions touchés
| Produit | Versions touchées | Corrigé en |
|---|---|---|
| Apache ActiveMQ AMQP 6.0 | 6.0.0 → < 6.2.8 | 6.2.8 |
| Apache ActiveMQ AMQP 5.19 | premières → < 5.19.9 | 5.19.9 |
| Apache ActiveMQ 6.0 | 6.0.0 → < 6.2.8 | 6.2.8 |
| Apache ActiveMQ 5.19 | premières → < 5.19.9 | 5.19.9 |
| Apache ActiveMQ All 6.0 | 6.0.0 → < 6.2.8 | 6.2.8 |
| Apache ActiveMQ All 5.19 | premières → < 5.19.9 | 5.19.9 |
Références
- lists.apache.org lists.apache.org
Chronologie
- Publiée
- Dernière modification