Aller au contenu
8.8 Élevée

CVE-2026-54232 vLLM is an inference and serving engine for large language models (LLMs)

Description

vLLM is an inference and serving engine for large language models (LLMs). Prior to 0.22.1, the vLLM Dockerfile is vulnerable to a dependency confusion attack through the flashinfer-jit-cache package. The package is installed from a custom index (flashinfer.ai/whl/) using --extra-index-url, but the package name was not registered on PyPI, and UV_INDEX_STRATEGY="unsafe-best-match" is set globally. An attacker who registers flashinfer-jit-cache on PyPI with version 0.6.11.post2 can execute arbitrary code as root during the Docker build and backdoor every resulting container image, enabling exfiltration of all user prompts, API credentials, and model data from production vLLM deployments This vulnerability is fixed in 0.22.1.

Produits et versions touchés

Produit Versions touchées Corrigé en
vllm 0.22 premières → < 0.22.1 0.22.1

Références

Chronologie

  1. Publiée
  2. Dernière modification
Les 121 CVE de vllm →
Suivre cette CVE