Aller au contenu
Non notée

CVE-2026-49432 Improper Input Validation vulnerability in Apache ActiveMQ, Apache ActiveMQ All, Apache ActiveMQ Stomp

Description

Improper Input Validation vulnerability in Apache ActiveMQ, Apache ActiveMQ All, Apache ActiveMQ Stomp. A remote unauthenticated peer that can reach an exposed STOMP connector can trigger denial-of-service behavior by sending a negative content-length. For the NIO STOMP transport, an attacker can keep streaming body bytes and grow the per-connection command buffer beyond configured limits to cause OOM. For the blocking STOMP protocol, an error will instead force abnormal transport exception handling for the affected connection and closure. This issue affects Apache ActiveMQ: before 5.19.8, from 6.0.0 before 6.2.7; Apache ActiveMQ All: before 5.19.8, from 6.0.0 before 6.2.7; Apache ActiveMQ Stomp: before 5.19.8, from 6.0.0 before 6.2.7. Users are recommended to upgrade to version 6.2.7 or 5.19.8, which fixes the issue.

Produits et versions touchés

Produit Versions touchées Corrigé en
Apache ActiveMQ 6.0 6.0.0 → < 6.2.7 6.2.7
Apache ActiveMQ 5.19 premières → < 5.19.8 5.19.8
Apache ActiveMQ All 6.0 6.0.0 → < 6.2.7 6.2.7
Apache ActiveMQ All 5.19 premières → < 5.19.8 5.19.8
Apache ActiveMQ Stomp 6.0 6.0.0 → < 6.2.7 6.2.7
Apache ActiveMQ Stomp 5.19 premières → < 5.19.8 5.19.8

Références

Chronologie

  1. Publiée
  2. Dernière modification
Les 40 CVE de Apache ActiveMQ →
Suivre cette CVE