Non notée
CVE-2026-44613 Cross-Site Request Forgery (CSRF) vulnerability in Apache Zeppelin
Description
Cross-Site Request Forgery (CSRF) vulnerability in Apache Zeppelin. The default CORS configuration allowed cross-origin state-changing requests and accepted text/plain request bodies, allowing an attacker who lures an authenticated user to a malicious site to perform actions on the user's behalf through REST and WebSocket endpoints. This issue affects Apache Zeppelin versions 0.6.0 through 0.12.0. Users are recommended to upgrade to version 0.12.1, which fixes this issue.
Produits et versions touchés
| Produit | Versions touchées | Corrigé en |
|---|---|---|
| Apache Zeppelin 0.6 | 0.6.0 → < 0.12.1 | 0.12.1 |
Références
- Apache Zeppelin PR #5229 github.com
- lists.apache.org lists.apache.org
Chronologie
- Publiée
- Dernière modification
Autres CVE de Apache Zeppelin
Les 25 CVE de Apache Zeppelin →
CVE-2026-44615
Path traversal vulnerability in Apache Zeppelin
Non notée
CVE-2026-44617
LDAP filter injection vulnerability in Apache Zeppelin
Non notée
CVE-2026-44616
LDAP injection vulnerability in Apache Zeppelin
Non notée
CVE-2024-51775
Missing Origin Validation in WebSockets vulnerability in Apache Zeppelin
Non notée