9.3
Critique
Exploitée
CVE-2026-42208 BerriAI LiteLLM SQL Injection Vulnerability
Exploitation active constatée
· catalogue CISA KEV
Action attendue
Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.
Campagnes de rançongiciel
Non constatée à ce jour
Faiblesse
CWE-89
Description
LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. From version 1.81.16 to before version 1.83.7, a database query used during proxy API key checks mixed the caller-supplied key value into the query text instead of passing it as a separate parameter. An unauthenticated attacker could send a specially crafted Authorization header to any LLM API route (for example POST /chat/completions) and reach this query through the proxy's error-handling path. An attacker could read data from the proxy's database and may be able to modify it, leading to unauthorised access to the proxy and the credentials it manages. This issue has been patched in version 1.83.7.
Produits et versions touchés
| Produit | Versions touchées | Corrigé en |
|---|---|---|
| litellm 1.81 | 1.81.16 → < 1.83.7 | 1.83.7 |
| Lightspeed Core | Versions non publiées | |
| Red Hat Ansible Automation Platform 2 | Versions non publiées | |
| Red Hat OpenShift AI (RHOAI) | Versions non publiées |
Références
- github.com github.com
- github.com github.com
Chronologie
- Publiée
- Ajoutée au catalogue KEV
- Dernière modification
Autres CVE de litellm
Les 40 CVE de litellm →
CVE-2026-114612
LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format
9.9
Critique
CVE-2026-108575
A vulnerability has been found in BerriAI LiteLLM up to 1.94.0
5.3
Moyenne
CVE-2026-108574
A flaw has been found in BerriAI LiteLLM up to 1.95.0
5.3
Moyenne
CVE-2026-93355
LiteLLM contains a weak authentication vulnerability that allows an attacker holding a valid JWT from the configured…
7.6
Élevée