Non notée
CVE-2026-32773 There is a lack of XSS escaping in the Spark History Server prior to 3.5.8 which allows a malicious Spark job to…
Description
There is a lack of XSS escaping in the Spark History Server prior to 3.5.8 which allows a malicious Spark job to generate arbitrary unescaped frontend code which could lead to a minimal privilege escalation in browser. Users are encouraged to upgrade to Spark 3.5.8 or later. This CVE is marked as "low" since the path to exploit requires both relatively high permissions (ability to launch a Spark job) and requires tricking a user with higher permissions to log in and visit the Spark history web page. Users are encouraged to upgrade their Spark history servers to Spark 3.5.8 or later.
Produits et versions touchés
| Produit | Versions touchées | Corrigé en |
|---|---|---|
| Apache Spark 3.0 | 3.0.0 → < 3.5.8 | 3.5.8 |
Références
- lists.apache.org lists.apache.org
Chronologie
- Publiée
- Dernière modification
Autres CVE de Apache Spark
Les 16 CVE de Apache Spark →
CVE-2025-54920
This issue affects Apache Spark: before 3.5.7 and 4.0.1
Non notée
CVE-2025-55039
This issue affects Apache Spark versions before 3.4.4, 3.5.2 and 4.0.0
Non notée
CVE-2024-23945
Signing cookies is an application security feature that adds a digital signature to cookie data to verify its…
Non notée
CVE-2023-32007
** UNSUPPORTED WHEN ASSIGNED ** The Apache Spark UI offers the possibility to enable ACLs via the configuration option…
Non notée