Aller au contenu
1.7 Faible

CVE-2026-27820 zlib is a Ruby interface for the zlib compression/decompression library

Description

zlib is a Ruby interface for the zlib compression/decompression library. Versions 3.0.0 and below, 3.1.0, 3.1.1, 3.2.0 and 3.2.1 contain a buffer overflow vulnerability in the Zlib::GzipReader. The zstream_buffer_ungets function prepends caller-provided bytes ahead of previously produced output but fails to guarantee the backing Ruby string has enough capacity before the memmove shifts the existing data. This can lead to memory corruption when the buffer length exceeds capacity. This issue has been fixed in versions 3.0.1, 3.1.2 and 3.2.3.

Produits et versions touchés

Produit Versions touchées Corrigé en
zlib 3.2 3.2.0 → < 3.2.3 3.2.3
zlib 3.1 3.1.0 → < 3.1.2 3.1.2
zlib 3.0 premières → < 3.0.1 3.0.1

Références

Chronologie

  1. Publiée
  2. Dernière modification
Suivre cette CVE