Aller au contenu
Non notée

CVE-2026-26929 Apache Airflow versions 3.0.0 through 3.1.7 FastAPI DagVersion listing API does not apply per-DAG authorization…

Description

Apache Airflow versions 3.0.0 through 3.1.7 FastAPI DagVersion listing API does not apply per-DAG authorization filtering when the request is made with dag_id set to "~" (wildcard for all DAGs). As a result, version metadata of DAGs that the requester is not authorized to access is returned. Users are recommended to upgrade to Apache Airflow 3.1.8 or later, which resolves this issue.

Produits et versions touchés

Produit Versions touchées Corrigé en
Apache Airflow 3.0 3.0.0 → < 3.1.8 3.1.8

Références

Chronologie

  1. Publiée
  2. Dernière modification
Les 153 CVE de Apache Airflow →
Suivre cette CVE