Aller au contenu
Non notée

CVE-2026-24733 Improper Input Validation vulnerability in Apache Tomcat

Description

Improper Input Validation vulnerability in Apache Tomcat. Tomcat did not limit HTTP/0.9 requests to the GET method. If a security constraint was configured to allow HEAD requests to a URI but deny GET requests, the user could bypass that constraint on GET requests by sending a (specification invalid) HEAD request using HTTP/0.9. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.14, from 10.1.0-M1 through 10.1.49, from 9.0.0.M1 through 9.0.112. Older, EOL versions are also affected. Users are recommended to upgrade to version 11.0.15 or later, 10.1.50 or later or 9.0.113 or later, which fixes the issue.

Produits et versions touchés

Produit Versions touchées Corrigé en
Apache Tomcat 11.0 11.0.0-M1 → 11.0.14 Pas de correctif indiqué
Apache Tomcat 10.1 10.1.0-M1 → 10.1.49 Pas de correctif indiqué
Apache Tomcat 9.0 9.0.0.M1 → 9.0.112 Pas de correctif indiqué
Apache Tomcat 8.5 premières → 8.5.100 Pas de correctif indiqué

Références

Chronologie

  1. Publiée
  2. Dernière modification
Les 141 CVE de Apache Tomcat →
Suivre cette CVE