Aller au contenu
7.1 Élevée

CVE-2026-23982 An Improper Authorization vulnerability exists in Apache Superset that allows a low-privileged user to bypass data…

Description

An Improper Authorization vulnerability exists in Apache Superset that allows a low-privileged user to bypass data access controls. When creating a dataset, Superset enforces permission checks to prevent users from querying unauthorized data. However, an authenticated attacker with permissions to write datasets and read charts can bypass these checks by overwriting the SQL query of an existing dataset. This issue affects Apache Superset: before 6.0.0. Users are recommended to upgrade to version 6.0.0, which fixes the issue.

Produits et versions touchés

Produit Versions touchées Corrigé en
Apache Superset 0.0 0.0.0 → < 6.0.0 6.0.0

Références

Chronologie

  1. Publiée
  2. Dernière modification
Les 65 CVE de Apache Superset →
Suivre cette CVE