Aller au contenu
5.3 Moyenne

CVE-2026-19113 Consul Community Edition and Consul Enterprise 1.3.0 through 2.0.2 are vulnerable to an unauthenticated denial of…

Description

Consul Community Edition and Consul Enterprise 1.3.0 through 2.0.2 are vulnerable to an unauthenticated denial of service in several agent HTTP API endpoints. A remote caller could cause the agent to consume substantial memory before the request was rejected. This vulnerability, CVE-2026-19113, is fixed in Consul 2.0.3 and Consul Enterprise 1.21.17, 1.22.11, and 2.0.3.

Produits et versions touchés

Produit Versions touchées Corrigé en
Consul 1.3 1.3.0 → < 2.0.3 2.0.3
Consul Enterprise 1.3 1.3.0 → < 2.0.3 2.0.3
Les 27 CVE de Consul →
Suivre cette CVE