Aller au contenu
5.3 Moyenne

CVE-2026-19012 Consul Community Edition and Consul Enterprise 1.18.0 through 2.0.2 are vulnerable to an authenticated denial of service…

Description

Consul Community Edition and Consul Enterprise 1.18.0 through 2.0.2 are vulnerable to an authenticated denial of service in the Enterprise-to-Community Edition downgrade path that may allow an authorized caller to crash the Consul server. A caller with config-entry write permission can submit a service-router configuration entry that causes the agent to exit unexpectedly. This vulnerability, CVE-2026-19012, is fixed in Consul 2.0.3 and Consul Enterprise 1.21.17, 1.22.11, and 2.0.3.

Produits et versions touchés

Produit Versions touchées Corrigé en
Consul 1.18 1.18.0 → < 2.0.3 2.0.3
Consul Enterprise 1.18 1.18.0 → < 2.0.3 2.0.3
Les 27 CVE de Consul →
Suivre cette CVE