8.8
Élevée
CVE-2026-18733 A prompt injection vulnerability in the shell tool in Amazon Strands Agents Tools before 0.8.0 might allow remote actors…
Description
A prompt injection vulnerability in the shell tool in Amazon Strands Agents Tools before 0.8.0 might allow remote actors to execute arbitrary operating system commands on the agent's host via a crafted prompt that sets the non_interactive parameter to true, bypassing the human consent gate. To remediate this issue, users should upgrade to version 0.8.0.
Produits et versions touchés
| Produit | Versions touchées | Corrigé en |
|---|---|---|
| strands-agents-tools 0.8 | premières → < 0.8.0 | 0.8.0 |