Aller au contenu
8.0 Élevée

CVE-2026-11400 An untrusted search path issue in the GlobalDatabasePlugin in the AWS Advanced JDBC Wrapper for Amazon Aurora PostgreSQL…

Description

An untrusted search path issue in the GlobalDatabasePlugin in the AWS Advanced JDBC Wrapper for Amazon Aurora PostgreSQL will allow a remote authenticated low-privilege actor to escalate privileges to those of another Amazon RDS user, including rds_superuser, via a crafted function created by the actor that runs when that user connects to the cluster through an affected wrapper. To remediate this issue, users should upgrade to AWS Advanced JDBC Wrapper version 4.0.1.

Produits et versions touchés

Produit Versions touchées Corrigé en
AWS Advanced JDBC Wrapper 3.0 3.0.0 → < 4.0.1 4.0.1
Les 3 CVE de AWS Advanced JDBC Wrapper →
Suivre cette CVE