Aller au contenu
8.8 Élevée

CVE-2026-103413 Improper input validation vulnerability in Apache Camel Karavan

Description

Improper input validation vulnerability in Apache Camel Karavan. When a deployment was started, Karavan unmarshalled a project's `kubernetes.yaml` and applied every resource it contained to the cluster without restricting the resource kinds, without rejecting security-sensitive pod options, and without pinning the target namespace. An authenticated user of any role could therefore have Karavan apply arbitrary Kubernetes resources within the reach of its service account, including pods requesting hostNetwork, hostPID, hostIPC, hostPath volumes, host ports, privileged containers, privilege escalation or added capabilities. This issue affects Apache Camel Karavan: from 4.0.0 before 4.22.1. Users are recommended to upgrade to version 4.22.1, which fixes the issue.

Produits et versions touchés

Produit Versions touchées Corrigé en
Apache Camel Karavan 4.0 4.0.0 → < 4.22.1 4.22.1

Références

Chronologie

  1. Publiée
  2. Dernière modification
Les 2 CVE de Apache Camel Karavan →
Suivre cette CVE