CVE-2025-55754 Improper Neutralization of Escape, Meta, or Control Sequences vulnerability in Apache Tomcat
Description
Improper Neutralization of Escape, Meta, or Control Sequences vulnerability in Apache Tomcat. Tomcat did not escape ANSI escape sequences in log messages. If Tomcat was running in a console on a Windows operating system, and the console supported ANSI escape sequences, it was possible for an attacker to use a specially crafted URL to inject ANSI escape sequences to manipulate the console and the clipboard and attempt to trick an administrator into running an attacker controlled command. While no attack vector was found, it may have been possible to mount this attack on other operating systems. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.10, from 10.1.0-M1 through 10.1.44, from 9.0.40 through 9.0.108. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.60 though 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.11 or later, 10.1.45 or later or 9.0.109 or later, which fix the issue.
Produits et versions touchés
| Produit | Versions touchées | Corrigé en |
|---|---|---|
| Apache Tomcat 11.0 | 11.0.0-M1 → 11.0.10 | Pas de correctif indiqué |
| Apache Tomcat 10.1 | 10.1.0-M1 → 10.1.44 | Pas de correctif indiqué |
| Apache Tomcat 10.0 | 10.0.0-M1 → 10.0.27 | Pas de correctif indiqué |
| Apache Tomcat 9.0 | 9.0.40 → 9.0.108 | Pas de correctif indiqué |
| Apache Tomcat 8.5 | 8.5.60 → 8.5.100 | Pas de correctif indiqué |
| Apache Tomcat 3 | 3 → < 8.5.0 | 8.5.0 |
| SIMATIC CN 4100 5.0 | premières → < 5.0 | 5.0 |
Références
- lists.apache.org lists.apache.org
Chronologie
- Publiée
- Dernière modification