Aller au contenu
5.8 Moyenne

CVE-2025-27888 Severity: medium (5.8) / important Server-Side Request Forgery (SSRF), Improper Neutralization of Input During Web…

Description

Severity: medium (5.8) / important Server-Side Request Forgery (SSRF), Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting'), URL Redirection to Untrusted Site ('Open Redirect') vulnerability in Apache Druid. This issue affects all previous Druid versions. When using the Druid management proxy, a request that has a specially crafted URL could be used to redirect the request to an arbitrary server instead. This has the potential for XSS or XSRF. The user is required to be authenticated for this exploit. The management proxy is enabled in Druid's out-of-box configuration. It may be disabled to mitigate this vulnerability. If the management proxy is disabled, some web console features will not work properly, but core functionality is unaffected. Users are recommended to upgrade to Druid 31.0.2 or Druid 32.0.1, which fixes the issue.

Produits et versions touchés

Produit Versions touchées Corrigé en
Apache Druid 32.0.0 Pas de correctif indiqué
Apache Druid 31.0 premières → < 31.0.2 31.0.2

Références

Chronologie

  1. Publiée
  2. Dernière modification
Les 11 CVE de Apache Druid →
Suivre cette CVE