Aller au contenu
Non notée

CVE-2025-23015 Privilege Defined With Unsafe Actions vulnerability in Apache Cassandra

Description

Privilege Defined With Unsafe Actions vulnerability in Apache Cassandra. An user with MODIFY permission ON ALL KEYSPACES can escalate privileges to superuser within a targeted Cassandra cluster via unsafe actions to a system resource. Operators granting data MODIFY permission on all keyspaces on affected versions should review data access rules for potential breaches. This issue affects Apache Cassandra through 3.0.30, 3.11.17, 4.0.15, 4.1.7, 5.0.2. Users are recommended to upgrade to versions 3.0.31, 3.11.18, 4.0.16, 4.1.8, 5.0.3, which fixes the issue.

Produits et versions touchés

Produit Versions touchées Corrigé en
Apache Cassandra 5.0 5.0.0 → 5.0.2 Pas de correctif indiqué
Apache Cassandra 4.1 4.1.0 → 4.1.7 Pas de correctif indiqué
Apache Cassandra 4.0 4.0.0 → 4.0.15 Pas de correctif indiqué
Apache Cassandra 3.1 3.1.0 → 3.11.17 Pas de correctif indiqué
Apache Cassandra 3.0 3.0.0 → 3.0.30 Pas de correctif indiqué

Références

Chronologie

  1. Publiée
  2. Dernière modification
Les 10 CVE de Apache Cassandra →
Suivre cette CVE